JGriffin's Blog

Is this thing on?

WebGL Conformance Tests now in GrafxBot

GrafxBot has been updated to include the mochitest version of the WebGL Conformance Tests.  When you run GrafxBot tests using the new version, it will run the usual reftests first, followed by the new WebGL tests.  Both sets of test results are posted to the database at the end of test.

The WebGL tests may be skipped for a couple of reasons:  they’ll be skipped if you have a Mac running less than 10.6, or if WebGL isn’t enabled in Firefox on your machine, which could happen if you don’t have supported hardware or drivers.  GrafxBot doesn’t try to force-enable either WebGL or accelerated layers.

Partially to support these tests, GrafxBot now reports some additional details about Firefox’s acceleration status, similar to what you see in about:support:

webgl results 132 pass / 7 fail
webgl renderer Google Inc. — ANGLE — OpenGL ES 2.0 (ANGLE 0.0.0.541)
acceleration mode 2/2 Direct3D 10
d2d enabled true
directwrite enabled true: 6.1.7600.20830, font cache n/a

I encourage users to download and run the new version; I’d like to get some feedback before I update it on AMO, to make sure users aren’t running into problems with the new tests.

The new version of GrafxBot can be downloaded here.

About these ads

13 responses to “WebGL Conformance Tests now in GrafxBot

  1. Benoit Jacob March 7, 2011 at 5:25 pm

    Thanks Jonathan, this is awesome work. Will check it ASAP.

  2. Barry M March 8, 2011 at 7:02 am

    Does this new test work with D3D9? I just seem to have a dead window with “WebGL Conformance Test Runner Status: Results: “, and a scrollable list box with no content. It’s been sitting that way for about 10 minutes. The rest of the test suite worked.

    Display Vendor: Mobile (0×8086)
    Display Adapter: Mobile Intel(R) 965 Express Chipset Family
    Display Chipset: 0x2A02
    Display RAM: 384 MB
    Display Drivers: igxprd32
    Driver Version: 6.14.10.5218, 1-13-2010
    Display Settings: 1440 x 900 x 32
    WebGL Renderer: Google Inc. — ANGLE — OpenGL ES 2.0 (ANGLE 0.0.0.541)
    Direct2D Enabled false
    DirectWrite Enabled false (0.0.0.0, font cache n/a)
    GPU Accelerated Windows 2/2 Direct3D 9

  3. MrX1980 May 21, 2011 at 11:21 pm

    Hello jagriffin,

    I cannot send the results of Grafx Bot.
    The send button is not working.

    Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110521 Firefox/6.0a1

    - Add-on Compatibility Reporter 0.8.3
    - Grafx Bot 0.2.01

    Can you please check this and make Grafx Bot 6.0a1/7.x compatible?

    Thanks
    MrX1980

    • RNik June 20, 2011 at 11:51 am

      Same here (Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110620 Firefox/7.0a1)

      Error Console throws this error:

      Error: CC['@mozilla.org/extensions/grafxbot/service;1'] is undefined
      Source File: chrome://grafxbot/content/testrunner.js
      Line: 92

  4. Gam August 10, 2011 at 5:27 am

    The Send-button isn’t working for me either, but the console is silent.

    - Firefox nightly 8.0a1 (2011-08-09)
    - 2.6.32-5-amd64 #1 SMP x86_64 GNU/Linux
    - GNOME user interface

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

Join 35 other followers

%d bloggers like this: